Library / Windows

dstokenclean.exe

Data Sharing Service Maintenance Driver · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • dstokenclean.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dstokenclean.exe'
    - OriginalFileName: 'dstokenclean.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dstokenclean.exe1x6410.0.26100.9444Host scan✓ 1

InternalName: Data Sharing Service Maintenance Driver · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
caae9bab010d…10.0.26100.9444x64dstokenclean.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.