Library / Windows

edmgen.exe

EdmGen.exe · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • EdmGen.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\edmgen.exe'
    - OriginalFileName: 'EdmGen.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
EdmGen.exe1x864.8.10001.0Host scan✓ 1

InternalName: EdmGen.exe · Product: Microsoft® .NET Framework

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
81af7e2e8502…4.8.10001.0x86EdmGen.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.