Library / Windows

ehstorauthn.exe

Microsoft Enhanced Storage Authentication Program · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • EhStorAuthn.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\ehstorauthn.exe'
    - OriginalFileName: 'EhStorAuthn.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
EhStorAuthn.exe2x64, x8610.0.26100.1 → 10.0.26100.1150Host scan✓ 2

InternalName: EhStorAuthn.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
15e47a9ccd64…10.0.26100.1150x64EhStorAuthn.exeHost scan✓
f063d73214e2…10.0.26100.1x86EhStorAuthn.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.