Library / LOLBin

esentutl.exe

Extensible Storage Engine Utilities for Microsoft(R) Windows(R) · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 3

OriginalFilename

  • esentutl.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\esentutl.exe'
    - OriginalFileName: 'esentutl.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
esentutl.exe15x64, x8610.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (9)Host scan, Winbindex✓ 2

InternalName: esentutl.exe · Product: Microsoft® Windows® Operating System

All 15 parsed builds · 23 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
eaee316a3f8d…10.0.28000.1896x86esentutl.exeWin11 26H1UnsignedWinbindex
36c889bf4551…10.0.28000.1896x64esentutl.exeWin11 26H1Winbindex
cd6e3a1998d8…10.0.26100.5074x86esentutl.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
8e2e2d15f28f…10.0.26100.3624x64esentutl.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
6363fbbdb2e8…10.0.14393.2999x64esentutl.exeWin10 1607UnsignedWinbindex
055c27cfc7d0…10.0.14393.2999x86esentutl.exeWin10 1607UnsignedWinbindex
a3ee005c46f1…10.0.17763.529x64esentutl.exeWin10 1809UnsignedWinbindex
f423aac49896…10.0.17134.799x64esentutl.exeWin10 1803UnsignedWinbindex
3bf7fc142d1c…10.0.17134.799x86esentutl.exeWin10 1803UnsignedWinbindex
4cf1b762b991…10.0.16299.1182x86esentutl.exeWin10 1709UnsignedWinbindex
3c919e5f694d…10.0.16299.1182x64esentutl.exeWin10 1709UnsignedWinbindex
842d3ec552be…10.0.10586.0x64esentutl.exeWin10 1511UnsignedWinbindex
097dcf8c7297…10.0.10586.0x86esentutl.exeWin10 1511UnsignedWinbindex
5bd1d1bfd7e9…10.0.10240.16384x64esentutl.exeWin10 1507UnsignedWinbindex
10804b7d0e83…10.0.10240.16384x86esentutl.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.