Library / Windows

eventcreate.exe

Event Create - Creates a custom event in an event log · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • evcreate.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: eventcreate.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\eventcreate.exe'
    - OriginalFileName: 'evcreate.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
evcreate.exe2x64, x8610.0.26100.4202Host scan✓ 2

InternalName: eventcreate.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d64cf3d8c861…10.0.26100.4202x64evcreate.exeHost scan✓
a8f4aebba033…10.0.26100.4202x86evcreate.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.