Library / LOLBin

findstr.exe

Find String (QGREP) Utility · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 17

OriginalFilename

  • FINDSTR.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\findstr.exe'
    - OriginalFileName: 'FINDSTR.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
FINDSTR.EXE12x64, x8610.0.10240.16384 → 10.0.28000.2804Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: findstr · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a6d8821ff2f8…10.0.28000.2804x86FINDSTR.EXEWin11 26H1UnsignedWinbindex
5ed347df3b7a…10.0.28000.2804x64FINDSTR.EXEWin11 26H1UnsignedWinbindex
867816f8a714…10.0.26100.7019x64FINDSTR.EXEWin11 24H2UnsignedHost scan, Winbindex✓
6902a39b3419…10.0.26100.7019x86FINDSTR.EXEWin11 24H2UnsignedHost scan, Winbindex✓
46bdb9125c43…10.0.26100.1150x64FINDSTR.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
eb3fc3c02880…10.0.26100.1x86FINDSTR.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
ea0c8f0ccb34…10.0.14393.0x86FINDSTR.EXEWin10 1607UnsignedWinbindex
2956f7bc8634…10.0.14393.0x64FINDSTR.EXEWin10 1607UnsignedWinbindex
d90fce5f0a3f…10.0.10586.0x86FINDSTR.EXEWin10 1511UnsignedWinbindex
7cb0f8324363…10.0.10586.0x64FINDSTR.EXEWin10 1511UnsignedWinbindex
1c639fbba837…10.0.10240.16384x64FINDSTR.EXEWin10 1507UnsignedWinbindex
18d401b5afcd…10.0.10240.16384x86FINDSTR.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.