Library / Windows

fodhelper.exe

Features On Demand Helper · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 2

OriginalFilename

  • FodHelper.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\fodhelper.exe'
    - OriginalFileName: 'FodHelper.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
FodHelper.EXE7x6410.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (7)Host scan, Winbindex✓ 1

InternalName: FodHelper · Product: Microsoft® Windows® Operating System

All 7 parsed builds · 13 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
af75598a78b5…10.0.28000.1896x64FodHelper.EXEWin11 26H1UnsignedWinbindex
ec9b0d09b56f…10.0.26100.1150x64FodHelper.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
9d29ddd628fd…10.0.26100.1x64FodHelper.EXEWin11 24H2UnsignedWinbindex
2b5089d56eb0…10.0.22000.71x64FodHelper.EXEWin11 21H2UnsignedWinbindex
9f9c61c92416…10.0.10586.0x64FodHelper.EXEWin10 1511UnsignedWinbindex
4346962b31d9…10.0.14393.0x64FodHelper.EXEWin10 1607UnsignedWinbindex
8a003a2f25c4…10.0.10240.16384x64FodHelper.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.