Library / LOLBin

forfiles.exe

ForFiles - Executes a command on selected files · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 9

OriginalFilename

  • forfiles.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\forfiles.exe'
    - OriginalFileName: 'forfiles.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
forfiles.exe11x64, x8610.0.10240.16384 → 10.0.26100.1150Win10 1507 → Win11 25H2 (6)Host scan, Winbindex✓ 2

InternalName: forfiles.exe · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 26 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
715b741d0646…10.0.26100.1150x64forfiles.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
d81a80fe8387…10.0.26100.1x86forfiles.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
751563f4ef08…10.0.26100.1x64forfiles.exeWin11 24H2UnsignedWinbindex
d6b22bfb82a6…10.0.16299.15x86forfiles.exeWin10 1709UnsignedWinbindex
ce5a6110e0c8…10.0.16299.15x64forfiles.exeWin10 1709UnsignedWinbindex
5b2ba93b56d9…10.0.14393.0x64forfiles.exeWin10 1607UnsignedWinbindex
092db9638240…10.0.14393.0x86forfiles.exeWin10 1607UnsignedWinbindex
cfd8bb79725e…10.0.10586.0x64forfiles.exeWin10 1511UnsignedWinbindex
2ee3fb56325f…10.0.10586.0x86forfiles.exeWin10 1511UnsignedWinbindex
9fc8838b805d…10.0.10240.16384x86forfiles.exeWin10 1507UnsignedWinbindex
470b7c1b4fcc…10.0.10240.16384x64forfiles.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.