Library / Windows

gpresult.exe

Query Group Policy RSOP Data · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • gprslt.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: gpresult.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\gpresult.exe'
    - OriginalFileName: 'gprslt.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
gprslt.exe15x64, x8610.0.10240.18725 → 10.0.26100.8115Win10 1507 → Win11 21H2 (11)Host scan, Winbindex✓ 2

InternalName: gpresult.exe · Product: Microsoft® Windows® Operating System

All 15 parsed builds · 20 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
35c503173053…10.0.10240.18725x86gprslt.exeWin10 1507UnsignedWinbindex
20fc82d33398…10.0.10240.18725x64gprslt.exeWin10 1507UnsignedWinbindex
cabaab045525…10.0.14393.3986x86gprslt.exeWin10 1607UnsignedWinbindex
0b50d2ee2453…10.0.14393.2457x64gprslt.exeWin10 1607UnsignedWinbindex
d5682e02cd35…10.0.22000.1042x64gprslt.exeWin11 21H2UnsignedWinbindex
8692599267ce…10.0.22000.1042x86gprslt.exeWin11 21H2UnsignedWinbindex
c5389b1d4e28…10.0.19041.1865x64gprslt.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
d4c00fbee122…10.0.19041.906x86gprslt.exeWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
678cf8bbd1b6…10.0.19041.906x64gprslt.exeWin10 2004 … Win10 21H2 (4)Signed (Catalog file)Winbindex
bb7ad61c283b…10.0.17134.1x86gprslt.exeWin10 1803UnsignedWinbindex
83b744f4b1d5…10.0.17134.1x64gprslt.exeWin10 1803UnsignedWinbindex
176a8cf86e47…10.0.15063.2525x64gprslt.exeWin10 1703UnsignedWinbindex
be8dca80c3ec…10.0.16299.2166x64gprslt.exeWin10 1709UnsignedWinbindex
a805fb8b099f…10.0.26100.8115x64gprslt.exeHost scan✓
a2f4c239d770…10.0.26100.8115x86gprslt.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.