Library / Windows

hcsdiag.exe

Hyper-V Host Compute Service Diagnostics Tool · Microsoft Corporation

WindowsParsed

OriginalFilename

  • Hyper-V Host Compute Service Diagnostics Tool

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: hcsdiag.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\hcsdiag.exe'
    - OriginalFileName: 'Hyper-V Host Compute Service Diagnostics Tool'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Hyper-V Host Compute Service Diagnostics Tool1x6410.0.26100.9278Host scan

InternalName: Hyper-V Host Compute Service Diagnostics Tool · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
9b2d905361f0…10.0.26100.9278x64Hyper-V Host Compute Service Diagnostics ToolHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.