Library / Sysinternals

hex2dec.exe

converts hex to decimal and vice versa · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • hex2dec.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as hex2dec64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\hex2dec.exe'
    - OriginalFileName: 'hex2dec.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
hex2dec.exe1x861.1.0.0Sysinternals✓ 1

InternalName: Hex2dec · Product: Sysinternals hex2dec

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
3e57cc1d455a…1.1.0.0x86hex2dec.exeSysinternals hex2decSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.