Library / Windows

hostname.exe

Hostname APP · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • hostname.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\hostname.exe'
    - OriginalFileName: 'hostname.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
hostname.exe11x64, x8610.0.10240.16384 → 10.0.28000.2804Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: hostname.exe · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
1caf048173c5…10.0.28000.2804x64hostname.exeWin11 26H1UnsignedWinbindex
8bf04644afc6…10.0.28000.1x86hostname.exeWin11 26H1UnsignedWinbindex
f8b207720d86…10.0.26100.9549x64hostname.exeWin11 24H2UnsignedHost scan, Winbindex✓
86c83e603936…10.0.26100.2161x86hostname.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
b8da5a3ae437…10.0.14393.0x64hostname.exeWin10 1607UnsignedWinbindex
5af3f9378633…10.0.14393.0x86hostname.exeWin10 1607UnsignedWinbindex
8ff283fb7a28…10.0.26100.2161x64hostname.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
c0e8cf64c458…10.0.10586.0x86hostname.exeWin10 1511UnsignedWinbindex
9bfe6070f4e1…10.0.10586.0x64hostname.exeWin10 1511UnsignedWinbindex
e2e96df6d4a6…10.0.10240.16384x86hostname.exeWin10 1507UnsignedWinbindex
c05f6b8105df…10.0.10240.16384x64hostname.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.