Library / Windows

hvc.exe

Hyper-V Command Line Tool · Microsoft Corporation

WindowsParsed

OriginalFilename

  • Hyper-V Command Line Tool

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: hvc.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\hvc.exe'
    - OriginalFileName: 'Hyper-V Command Line Tool'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Hyper-V Command Line Tool1x6410.0.26100.9278Host scan

InternalName: Hyper-V Command Line Tool · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
cab324823d17…10.0.26100.9278x64Hyper-V Command Line ToolHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.