Library / Windows

hvsisettingsworker.exe

Microsoft Defender Application Guard · Microsoft Corporation

WindowsParsed

OriginalFilename

  • HvsiSettingsWorker.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\hvsisettingsworker.exe'
    - OriginalFileName: 'HvsiSettingsWorker.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
HvsiSettingsWorker.exe1x6410.0.26100.9278Host scan

InternalName: HvsiSettingsWorker.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
fbe1d19c6bef…10.0.26100.9278x64HvsiSettingsWorker.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.