Library / Windows

icacls.exe

Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • iCACLS.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\icacls.exe'
    - OriginalFileName: 'iCACLS.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
iCACLS.EXE2x64, x8610.0.26100.1882Host scan✓ 2

InternalName: icacls · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
cb9e55d4c02f…10.0.26100.1882x64iCACLS.EXEHost scan✓
a02445dbd6a3…10.0.26100.1882x86iCACLS.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.