Library / LOLBin

ieadvpack.dll

ADVPACK · Microsoft Corporation

LOLBinWindowsParsedLOLBAS

OriginalFilename

  • ADVPACK.DLL

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: ieadvpack.dll never fires.
  • Same OriginalFilename as advpack.dll, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\ieadvpack.dll'
    - OriginalFileName: 'ADVPACK.DLL'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
ADVPACK.DLL30x64, x8611.0.10240.17738 → 11.0.28000.2179Win10 1507 → Win11 26H1 (20)Winbindex

InternalName: ADVPACK.DLL · Product: Internet Explorer

All 30 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
ef31d6b70fe4…11.0.28000.2179x86ADVPACK.DLLWin11 26H1Winbindex
a78491ef2933…11.0.28000.1896x64ADVPACK.DLLWin11 26H1Winbindex
4649127f54c1…11.0.26100.8328x86ADVPACK.DLLWin11 24H2UnsignedWinbindex
692b72287584…11.0.26100.8115x64ADVPACK.DLLWin11 24H2UnsignedWinbindex
ee2d04c7889a…11.0.22621.3527x86ADVPACK.DLLWin11 22H2, Win11 23H2UnsignedWinbindex
be64f53fb376…11.0.22621.3527x64ADVPACK.DLLWin11 22H2, Win11 23H2UnsignedWinbindex
efeb1c0931b7…11.0.19041.4355x64ADVPACK.DLLWin10 21H2, Win10 22H2UnsignedWinbindex
907947fca16f…11.0.19041.4355x86ADVPACK.DLLWin10 21H2, Win10 22H2UnsignedWinbindex
617b29a53c7c…11.0.14393.2007x64ADVPACK.DLLWin10 1607UnsignedWinbindex
4dbc811989ce…11.0.14393.2007x86ADVPACK.DLLWin10 1607UnsignedWinbindex
fba61168db57…11.0.26100.2454x86ADVPACK.DLLWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
4b434155d3cd…11.0.26100.2454x64ADVPACK.DLLWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
5d56bac8610a…11.0.10240.17738x64ADVPACK.DLLWin10 1507UnsignedWinbindex
57acdf7c9ef2…11.0.10240.17738x86ADVPACK.DLLWin10 1507UnsignedWinbindex
4b31650b4fbd…11.0.22000.2600x64ADVPACK.DLLWin11 21H2Winbindex
307224eb0513…11.0.22000.2600x86ADVPACK.DLLWin11 21H2Winbindex
c4b652038665…11.0.19041.1x64ADVPACK.DLLWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
304d1b1731b2…11.0.19041.1x86ADVPACK.DLLWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
bc2ab8e8152b…11.0.15063.850x64ADVPACK.DLLWin10 1703UnsignedWinbindex
5e331e498c65…11.0.15063.850x86ADVPACK.DLLWin10 1703UnsignedWinbindex
5abd796de90c…11.0.16299.371x86ADVPACK.DLLWin10 1709UnsignedWinbindex
3d886a67cf2c…11.0.16299.371x64ADVPACK.DLLWin10 1709UnsignedWinbindex
e8fe8fd89066…11.0.18362.1x64ADVPACK.DLLWin10 1903, Win10 1909Signed (Catalog file)Winbindex
651fdfd7aedf…11.0.18362.1x86ADVPACK.DLLWin10 1903, Win10 1909Signed (Catalog file)Winbindex
f434c7674146…11.0.17763.1x86ADVPACK.DLLWin10 1809UnsignedWinbindex
457ca51bc94f…11.0.17763.1x64ADVPACK.DLLWin10 1809UnsignedWinbindex
2e4cc19c3284…11.0.17134.1x64ADVPACK.DLLWin10 1803UnsignedWinbindex
175cff5be164…11.0.17134.1x86ADVPACK.DLLWin10 1803UnsignedWinbindex
666c3270553b…11.0.10586.1356x86ADVPACK.DLLWin10 1511UnsignedWinbindex
40bb99c8d397…11.0.10586.1356x64ADVPACK.DLLWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.