Library / Windows

iechooser.exe

F12 Attach Chooser executable · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • F12Chooser.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: iechooser.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\iechooser.exe'
    - OriginalFileName: 'F12Chooser.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
F12Chooser.exe2x64, x8611.0.26100.5074 → 11.0.26100.8328Host scan✓ 2

InternalName: F12Chooser.exe · Product: Internet Explorer

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
628304b7daf3…11.0.26100.8328x86F12Chooser.exeHost scan✓
838a209e1a46…11.0.26100.5074x64F12Chooser.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.