Library / LOLBin

iediagcmd.exe

Diagnostics utility for Internet Explorer · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBAS

OriginalFilename

  • IEDiagCmd.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\iediagcmd.exe'
    - OriginalFileName: 'IEDiagCmd.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
IEDiagCmd.exe15x6411.0.10240.19325 → 11.0.28000.2605Win10 1507 → Win11 26H1 (20)Host scan, Winbindex✓ 1

InternalName: IEDiagCmd.exe · Product: Internet Explorer

All 15 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
571f4ae2e447…11.0.28000.2605x64IEDiagCmd.exeWin11 26H1Winbindex
344cc34b1296…11.0.26100.9278x64IEDiagCmd.exeWin11 24H2UnsignedHost scan, Winbindex✓
0ec05d16b1ae…11.0.22621.2506x64IEDiagCmd.exeWin11 22H2, Win11 23H2UnsignedWinbindex
753e58a658c2…11.0.19041.3636x64IEDiagCmd.exeWin10 21H2, Win10 22H2UnsignedWinbindex
a39a27b09505…11.0.17763.1432x64IEDiagCmd.exeWin10 1809Signed (Catalog file)Winbindex
d109357a9794…11.0.14393.8864x64IEDiagCmd.exeWin10 1607UnsignedWinbindex
a47a34074a1b…11.0.10240.19325x64IEDiagCmd.exeWin10 1507UnsignedWinbindex
387902708e4c…11.0.26100.6584x64IEDiagCmd.exeWin11 24H2, Win11 25H2UnsignedWinbindex
c6aa1294f6a5…11.0.19041.1x64IEDiagCmd.exeWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
85bc7bfb6ca9…11.0.18362.1049x64IEDiagCmd.exeWin10 1903, Win10 1909UnsignedWinbindex
a8840aee149a…11.0.22000.1x64IEDiagCmd.exeWin11 21H2UnsignedWinbindex
502fc1a71641…11.0.17134.982x64IEDiagCmd.exeWin10 1803UnsignedWinbindex
d50384962fd1…11.0.16299.1653x64IEDiagCmd.exeWin10 1709UnsignedWinbindex
5c7b196e6ded…11.0.15063.0x64IEDiagCmd.exeWin10 1703UnsignedWinbindex
81db21ce0dd7…11.0.10586.0x64IEDiagCmd.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.