Library / Windows

imtcprop.exe

IMTCPROP.exe · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • IMTCPROP.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\imtcprop.exe'
    - OriginalFileName: 'IMTCPROP.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
IMTCPROP.exe2x64, x8610.0.26100.9549Host scan✓ 2

InternalName: IMTCPROP.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
aa5fea30913b…10.0.26100.9549x86IMTCPROP.exeHost scan✓
79cf85611bdc…10.0.26100.9549x64IMTCPROP.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.