Library / Sysinternals

junction.exe

Creates and lists directory links · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • junction.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as junction64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\junction.exe'
    - OriginalFileName: 'junction.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
junction.exe1x861.7.0.0Sysinternals✓ 1

InternalName: Junction · Product: Sysinternals Junction

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6fb4df6555a6…1.7.0.0x86junction.exeSysinternals JunctionSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.