Library / Windows

ksetup.exe

Kerberos Setup tool · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 2

OriginalFilename

  • ksetup.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\ksetup.exe'
    - OriginalFileName: 'ksetup.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
ksetup.exe6x64, x8610.0.10240.19177 → 10.0.26100.1150Win10 1507 → Win11 25H2 (5)Host scan, Winbindex✓ 1

InternalName: ksetup.exe · Product: Microsoft® Windows® Operating System

All 6 parsed builds · 16 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f41c650adb4b…10.0.14393.4886x64ksetup.exeWin10 1607UnsignedWinbindex
2593a6666f11…10.0.14393.4886x86ksetup.exeWin10 1607UnsignedWinbindex
44cae1da003e…10.0.10240.19177x64ksetup.exeWin10 1507UnsignedWinbindex
f26cf54bc77c…10.0.26100.1150x64ksetup.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
335fd5f07c58…10.0.26100.1x64ksetup.exeWin11 24H2UnsignedWinbindex
b62d9fe454cd…10.0.10586.0x64ksetup.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.