Library / Windows

languagecomponentsinstallercomhandler.exe

LanguageComponentsInstaller COM Handler · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • LanguageComponentsInstallerComHandler.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\languagecomponentsinstallercomhandler.exe'
    - OriginalFileName: 'LanguageComponentsInstallerComHandler.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
LanguageComponentsInstallerComHandler.exe1x6410.0.26100.9278Host scan✓ 1

InternalName: LanguageComponentsInstallerComHandler · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
c9bbc084334e…10.0.26100.9278x64LanguageComponentsInstallerComHandler.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.