Library / Sysinternals

logonsessions.exe

Lists logon session information · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • logonsessions.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as logonsessions64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\logonsessions.exe'
    - OriginalFileName: 'logonsessions.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
logonsessions.exe1x861.41.0.0Sysinternals✓ 1

InternalName: LogonSessions · Product: Sysinternals LogonSessions

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
8b3f67426e57…1.41.0.0x86logonsessions.exeSysinternals LogonSessionsSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.