Library / Windows

mdmdiagnosticstool.exe

MdmDiagnosticsTool · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • MdmDiagnosticsTool.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\mdmdiagnosticstool.exe'
    - OriginalFileName: 'MdmDiagnosticsTool.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
MdmDiagnosticsTool.exe1x6410.0.26100.9278Host scan✓ 1

InternalName: MdmDiagnosticsTool · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a52e7c10e823…10.0.26100.9278x64MdmDiagnosticsTool.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.