Library / Windows

mfpmp.exe

Media Foundation Protected Pipeline EXE · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • mf.dll

Differs from file nameNames a DLL

Gotchas

  • OriginalFilename names a DLL (mf.dll), not an executable. Rules expecting .exe values miss it.
  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: mfpmp.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\mfpmp.exe'
    - OriginalFileName: 'mf.dll'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
mf.dll2x64, x8610.0.26100.7309Host scan✓ 2

InternalName: Media Foundation Protected Pipeline EXE · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b5a4203ac246…10.0.26100.7309x64mf.dllHost scan✓
7fc56bdee78e…10.0.26100.7309x86mf.dllHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.