Library / LOLBin

microsoft.workflow.compiler.exe

Microsoft.Workflow.Compiler.exe · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBAS

OriginalFilename

  • Microsoft.Workflow.Compiler.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\microsoft.workflow.compiler.exe'
    - OriginalFileName: 'Microsoft.Workflow.Compiler.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Microsoft.Workflow.Compiler.exe13x864.6.79.0 → 4.8.10001.0Win10 1507 → Win11 25H2 (19)Host scan, Winbindex✓ 1

InternalName: Microsoft.Workflow.Compiler.exe · Product: Microsoft® .NET Framework

All 13 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
e24bde224828…4.8.9221.0x86Microsoft.Workflow.Compiler.exeWin11 25H2Signed (Overlay)Winbindex
c109c2535b25…4.8.9032.0x86Microsoft.Workflow.Compiler.exeWin11 22H2 … Win11 24H2 (3)Signed (Overlay)Winbindex
698be205bc33…4.8.4084.0x86Microsoft.Workflow.Compiler.exeWin10 2004 … Win10 22H2 (5)Signed (Overlay)Winbindex
585f531a76b8…4.8.4161.0x86Microsoft.Workflow.Compiler.exeWin11 21H2Signed (Overlay)Winbindex
bc60cee98a6a…4.8.3752.0x86Microsoft.Workflow.Compiler.exeWin10 1903, Win10 1909Signed (Overlay)Winbindex
a5d8daa7731f…4.7.3190.0x86Microsoft.Workflow.Compiler.exeWin10 1809Signed (Overlay)Winbindex
4ccf5793503d…4.7.3056.0x86Microsoft.Workflow.Compiler.exeWin10 1803Signed (Overlay)Winbindex
45e7550909ea…4.7.2556.0x86Microsoft.Workflow.Compiler.exeWin10 1709Signed (Overlay)Winbindex
6f4b3ee0fd6e…4.7.2046.0x86Microsoft.Workflow.Compiler.exeWin10 1703Signed (Overlay)Winbindex
d961ecdec1ca…4.6.1586.0x86Microsoft.Workflow.Compiler.exeWin10 1607Signed (Overlay)Winbindex
64780aabfc29…4.6.1038.0x86Microsoft.Workflow.Compiler.exeWin10 1511Signed (Overlay)Winbindex
9720233a3b1c…4.6.79.0x86Microsoft.Workflow.Compiler.exeWin10 1507Signed (Overlay)Winbindex
cfbddc209d37…4.8.10001.0x86Microsoft.Workflow.Compiler.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.