Library / Windows

microsoftedgedevtools.exe

Microsoft Edge Content Process · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • MicrosoftEdgeCP.exe

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: microsoftedgedevtools.exe never fires.
  • Same OriginalFilename as microsoftedgebchost.exe, microsoftedgecp.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\microsoftedgedevtools.exe'
    - OriginalFileName: 'MicrosoftEdgeCP.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
MicrosoftEdgeCP.exe1x6411.0.26100.8115Host scan✓ 1

InternalName: MicrosoftEdgeCP · Product: Microsoft Edge Web Platform

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
4bb852d856f9…11.0.26100.8115x64MicrosoftEdgeCP.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.