Library / Windows

microsoftedgesh.exe

Microsoft Edge Web Platform · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • MicrosoftEdgeSH.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\microsoftedgesh.exe'
    - OriginalFileName: 'MicrosoftEdgeSH.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
MicrosoftEdgeSH.exe1x6411.0.26100.8115Host scan✓ 1

InternalName: MicrosoftEdgeSH · Product: Microsoft Edge Web Platform

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d3537c345652…11.0.26100.8115x64MicrosoftEdgeSH.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.