Library / Windows

mlenginestub.exe

Undocked MLEngine Stub · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • MLEngineStub

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: mlenginestub.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\mlenginestub.exe'
    - OriginalFileName: 'MLEngineStub'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
MLEngineStub1x6410.0.26100.9278Host scan✓ 1

InternalName: MLEngineStub · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
12374e23c9aa…10.0.26100.9278x64MLEngineStubHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.