Library / LOLBin

mofcomp.exe

The Managed Object Format (MOF) Compiler · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • mofcomp.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\mofcomp.exe'
    - OriginalFileName: 'mofcomp.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
mofcomp.exe17x64, x8610.0.10240.17797 → 10.0.28000.3231Win10 1507 → Win11 26H1 (9)Host scan, Winbindex✓ 2

InternalName: mofcomp.exe · Product: Microsoft® Windows® Operating System

All 17 parsed builds · 23 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
ca1a06b38f24…10.0.28000.3231x64mofcomp.exeWin11 26H1UnsignedWinbindex
76e755d27328…10.0.26100.9711x86mofcomp.exeWin11 24H2UnsignedHost scan, Winbindex✓
200319f859dd…10.0.26100.9711x64mofcomp.exeWin11 24H2UnsignedHost scan, Winbindex✓
669f1482eff9…10.0.14393.9611x86mofcomp.exeWin10 1607UnsignedWinbindex
514d02cd30f6…10.0.14393.9611x64mofcomp.exeWin10 1607UnsignedWinbindex
1a0c3817288e…10.0.28000.1450x86mofcomp.exeWin11 26H1UnsignedWinbindex
c999b75c78e1…10.0.10240.17797x86mofcomp.exeWin10 1507UnsignedWinbindex
557a8a1caf9f…10.0.10240.17797x64mofcomp.exeWin10 1507UnsignedWinbindex
c62d20b7df88…10.0.26100.5074x64mofcomp.exeWin11 24H2, Win11 25H2UnsignedWinbindex
40fbe17a3a29…10.0.26100.5074x86mofcomp.exeWin11 24H2, Win11 25H2UnsignedWinbindex
1289716a5bf9…10.0.17134.1x64mofcomp.exeWin10 1803UnsignedWinbindex
ff02023bd6ac…10.0.19041.610x86mofcomp.exeWin10 2004UnsignedWinbindex
c6997c7079f9…10.0.19041.610x64mofcomp.exeWin10 2004UnsignedWinbindex
ab39ba677b87…10.0.16299.402x86mofcomp.exeWin10 1709UnsignedWinbindex
442e955d1582…10.0.16299.402x64mofcomp.exeWin10 1709UnsignedWinbindex
cb62a7e00316…10.0.10586.0x64mofcomp.exeWin10 1511UnsignedWinbindex
8bd7380f1496…10.0.10586.0x86mofcomp.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.