Library / Windows

monotificationuxstub.exe

Undocked MoNotificationUx Stub · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • MoNotificationUxStub

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: monotificationuxstub.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\monotificationuxstub.exe'
    - OriginalFileName: 'MoNotificationUxStub'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
MoNotificationUxStub1x6410.0.26100.8115Host scan✓ 1

InternalName: MoNotificationUxStub · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
0e8c5884bb51…10.0.26100.8115x64MoNotificationUxStubHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.