Library / Windows

mpnotify.exe

Windows NT Multiple Provider Notification Application · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • mpnotify.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\mpnotify.exe'
    - OriginalFileName: 'mpnotify.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
mpnotify.exe1x6410.0.26100.1Host scan✓ 1

InternalName: mpnotify.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
14b225a8a305…10.0.26100.1x64mpnotify.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.