Library / Windows

mpsigstub.exe

Microsoft Malware Protection Signature Update Stub · Microsoft Corporation

WindowsParsed

OriginalFilename

  • MpSigStub.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\mpsigstub.exe'
    - OriginalFileName: 'MpSigStub.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
MpSigStub.exe1x641.1.24010.2001Host scan

InternalName: MpSigStub.exe · Product: Microsoft Malware Protection

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
071b0d3a0850…1.1.24010.2001x64MpSigStub.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.