Library / LOLBin

msconfig.exe

System Configuration Utility · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBAS

OriginalFilename

  • msconfig.EXE

Some builds lack OriginalFilename

Gotchas

  • 1 observed build carry no OriginalFilename at all.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\msconfig.exe'
    - OriginalFileName: 'msconfig.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
msconfig.EXE10x6410.0.10240.19003 → 10.0.28000.2804Win10 1507 → Win11 26H1 (13)Host scan, Winbindex✓ 1
none1x641.0.0.1Win10 1607Winbindex

InternalName: msconfig.EXE · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 6 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f7b668fe595d…10.0.28000.2804x64msconfig.EXEWin11 26H1Winbindex
2927c4629736…10.0.26100.9549x64msconfig.EXEWin11 24H2UnsignedHost scan, Winbindex✓
62f302a1ba4c…1.0.0.1x64noneWin10 1607UnsignedWinbindex
55f8c0ee2350…10.0.17763.2061x64msconfig.EXEWin10 1809UnsignedWinbindex
0a6e60cf6f59…10.0.26100.5074x64msconfig.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
fb580565f1f8…10.0.10240.19003x64msconfig.EXEWin10 1507UnsignedWinbindex
ebc6a1019c2f…10.0.22000.653x64msconfig.EXEWin11 21H2UnsignedWinbindex
93d2604f7fdf…10.0.19041.1110x64msconfig.EXEWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
b037bae54ffd…10.0.18362.1679x64msconfig.EXEWin10 1909UnsignedWinbindex
f2ca6d1784f9…10.0.16299.15x64msconfig.EXEWin10 1709UnsignedWinbindex
c7a7569c1b7a…10.0.10586.0x64msconfig.EXEWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.