Library / Windows

msdtc.exe

Microsoft Distributed Transaction Coordinator Service · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 2

OriginalFilename

  • MSDTC.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\msdtc.exe'
    - OriginalFileName: 'MSDTC.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
MSDTC.EXE7x642001.12.10941.16384 → 2001.12.10941.16506Win10 1507 → Win11 26H1 (7)Host scan, Winbindex✓ 1

InternalName: MSDTC.EXE · Product: Microsoft® Windows® Operating System

All 7 parsed builds · 13 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
e14b0fa4c48f…2001.12.10941.16384x64MSDTC.EXEWin11 26H1UnsignedWinbindex
bc1f5e9adfd3…2001.12.10941.16384x64MSDTC.EXEWin11 24H2UnsignedHost scan, Winbindex✓
299b2808e244…2001.12.10941.16384x64MSDTC.EXEWin10 1809UnsignedWinbindex
c1866b5cb01f…2001.12.10941.16384x64MSDTC.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
99750b504de9…2001.12.10941.16506x64MSDTC.EXEWin10 1507UnsignedWinbindex
72db45ca11fe…2001.12.10941.16384x64MSDTC.EXEWin10 1607UnsignedWinbindex
f275645f4f0d…2001.12.10941.16384x64MSDTC.EXEWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.