Library / Windows

narrator.exe

Screen Reader · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • SR.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: narrator.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\narrator.exe'
    - OriginalFileName: 'SR.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
SR.exe1x6410.0.26100.9711Host scan✓ 1

InternalName: SR.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
96d2ca6a6391…10.0.26100.9711x64SR.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.