Library / Windows

nbtstat.exe

TCP/IP NetBios Information · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • nbtinfo.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: nbtstat.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\nbtstat.exe'
    - OriginalFileName: 'nbtinfo.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
nbtinfo.exe6x6410.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 1

InternalName: nbtinfo.exe · Product: Microsoft® Windows® Operating System

All 6 parsed builds · 14 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
7ec36aba70d9…10.0.28000.1896x64nbtinfo.exeWin11 26H1Winbindex
4b5abcd833a8…10.0.26100.1150x64nbtinfo.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
61a4edc6552c…10.0.26100.1x64nbtinfo.exeWin11 24H2UnsignedWinbindex
41c05b8342ad…10.0.14393.0x64nbtinfo.exeWin10 1607UnsignedWinbindex
67a2d92d0fd9…10.0.10586.0x64nbtinfo.exeWin10 1511UnsignedWinbindex
ab6a303d0fd0…10.0.10240.16384x64nbtinfo.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.