Library / Windows

ndkperfcmd.exe

RDMA Perf Cmd · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • RdmaPerf.sys

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: ndkperfcmd.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\ndkperfcmd.exe'
    - OriginalFileName: 'RdmaPerf.sys'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
RdmaPerf.sys1x6410.0.26100.1150Host scan✓ 1

InternalName: RdmaPerf.sys · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
2c4aee4b8709…10.0.26100.1150x64RdmaPerf.sysHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.