Library / Windows

netcfgnotifyobjecthost.exe

Host Process for Network Driver Configuration Plugins · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • NetCfgNotifyObjectHost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\netcfgnotifyobjecthost.exe'
    - OriginalFileName: 'NetCfgNotifyObjectHost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
NetCfgNotifyObjectHost.exe2x64, x8610.0.26100.8115 → 10.0.26100.9278Host scan✓ 2

InternalName: NetCfgNotifyObjectHost.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
668f8191e128…10.0.26100.9278x64NetCfgNotifyObjectHost.exeHost scan✓
7086f2e11ebf…10.0.26100.8115x86NetCfgNotifyObjectHost.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.