Library / LOLBin

netsh.exe

Network Command Shell · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 18

OriginalFilename

  • netsh.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\netsh.exe'
    - OriginalFileName: 'netsh.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
netsh.exe12x64, x8610.0.10240.16384 → 10.0.28000.2179Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: netsh.exe · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
c8e915989db9…10.0.28000.2179x86netsh.exeWin11 26H1UnsignedWinbindex
945cbb6ec2db…10.0.28000.2179x64netsh.exeWin11 26H1UnsignedWinbindex
e16f0ef226e2…10.0.26100.8328x86netsh.exeWin11 24H2UnsignedHost scan, Winbindex✓
b4fe2ea236ed…10.0.26100.8328x64netsh.exeWin11 24H2UnsignedHost scan, Winbindex✓
9f62b477c197…10.0.26100.5074x64netsh.exeWin11 24H2, Win11 25H2UnsignedWinbindex
6a3e084827c4…10.0.26100.5074x86netsh.exeWin11 24H2, Win11 25H2UnsignedWinbindex
e5888e649c88…10.0.14393.0x64netsh.exeWin10 1607UnsignedWinbindex
00b424fce60e…10.0.14393.0x86netsh.exeWin10 1607UnsignedWinbindex
329326ac87ca…10.0.10586.0x86netsh.exeWin10 1511UnsignedWinbindex
1651ff286ddd…10.0.10586.0x64netsh.exeWin10 1511UnsignedWinbindex
e9e24fb71b09…10.0.10240.16384x86netsh.exeWin10 1507UnsignedWinbindex
9d726eefa3d5…10.0.10240.16384x64netsh.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.