Library / Windows

newdev.exe

Device driver software installation · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • NewDev.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\newdev.exe'
    - OriginalFileName: 'NewDev.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
NewDev.EXE2x64, x865.2.3668.0Host scan✓ 2

InternalName: NewDev.EXE · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
654e232bb12b…5.2.3668.0x64NewDev.EXEHost scan✓
04dd5a333cb2…5.2.3668.0x86NewDev.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.