Library / Windows

ngciso.exe

Windows Hello Security Process · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • NgcIso.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\ngciso.exe'
    - OriginalFileName: 'NgcIso.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
NgcIso.exe1x6410.0.26100.9711Host scan✓ 1

InternalName: NgcIso.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
1704e647b767…10.0.26100.9711x64NgcIso.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.