Library / Windows

ngentask.exe

Microsoft .NET Framework optimization service · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • NGenTask.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\ngentask.exe'
    - OriginalFileName: 'NGenTask.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
NGenTask.exe2x64, x864.8.10002.0Host scan✓ 2

InternalName: NGenTask.exe · Product: Microsoft® .NET Framework

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
737c36ec3751…4.8.10002.0x86NGenTask.exeHost scan✓
47fa996723f2…4.8.10002.0x64NGenTask.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.