Library / Windows

nmbind.exe

Hyper-V Network Core Bind Application · Microsoft Corporation

WindowsParsed

OriginalFilename

  • corebind.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: nmbind.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\nmbind.exe'
    - OriginalFileName: 'corebind.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
corebind.exe1x6410.0.26100.9549Host scan

InternalName: Hyper-V Network Core Bind Application · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f7b0f5e37d1b…10.0.26100.9549x64corebind.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.