Library / Sysinternals

notmyfault.exe

Driver Bug Test Program · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • NotMyfault.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as notmyfault64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\notmyfault.exe'
    - OriginalFileName: 'NotMyfault.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
NotMyfault.exe1x864.60.0.0Sysinternals✓ 1

InternalName: Sysinternals NotMyfault · Product: Sysinternals NotMyfault

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a4e1b83a841f…4.60.0.0x86NotMyfault.exeSysinternals NotMyfaultSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.