Library / Sysinternals

notmyfaultc64.exe

Driver Bug Test Command-Line Program · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • NotMyfaultC.exe

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: notmyfaultc64.exe never fires.
  • Same OriginalFilename as notmyfaultc.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\notmyfaultc64.exe'
    - OriginalFileName: 'NotMyfaultC.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
NotMyfaultC.exe1x644.60.0.0Sysinternals✓ 1

InternalName: Sysinternals NotMyfaultC · Product: Sysinternals NotMyfault

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
751656c6a246…4.60.0.0x64NotMyfaultC.exeSysinternals NotMyfaultSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.