Library / Windows

npcaphelper.exe

The helper program for "Admin-only Mode" · Nmap Software LLC

WindowsParsed

OriginalFilename

  • NpcapHelper.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\npcaphelper.exe'
    - OriginalFileName: 'NpcapHelper.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
NpcapHelper.exe2x64, x865.1.88.504Host scan

InternalName: NpcapHelper.exe · Product: Npcap

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d8153148a2d8…5.1.88.504x64NpcapHelper.exeHost scan
8ecd771e11f3…5.1.88.504x86NpcapHelper.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.