Library / LOLBin

ntdsutil.exe

NT5DS · Microsoft Corporation

LOLBinWindowsParsedLOLBASSigma refs: 3

OriginalFilename

  • ntdsutil.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\ntdsutil.exe'
    - OriginalFileName: 'ntdsutil.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
ntdsutil.exe15x64, x8610.0.14393.5648 → 10.0.28000.2804Win10 1607 → Win11 26H1 (9)Winbindex

InternalName: ntdsutil.exe · Product: Microsoft® Windows® Operating System

All 15 parsed builds · 7 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
74ccbf6d3c6c…10.0.28000.2804x86ntdsutil.exeWin11 26H1Winbindex
3b9ffb2ec642…10.0.28000.2804x64ntdsutil.exeWin11 26H1Winbindex
ff137444c71f…10.0.26100.8875x64ntdsutil.exeWin11 24H2UnsignedWinbindex
ede2856006ce…10.0.14393.5648x64ntdsutil.exeWin10 1607UnsignedWinbindex
ed2dccd127ed…10.0.14393.5648x86ntdsutil.exeWin10 1607UnsignedWinbindex
19dfe0ffd2f4…10.0.26100.7309x86ntdsutil.exeWin11 24H2Winbindex
36256a729c4a…10.0.22000.2777x64ntdsutil.exeWin11 21H2UnsignedWinbindex
68f2935205aa…10.0.19041.1466x64ntdsutil.exeWin10 20H2UnsignedWinbindex
3d03926689c4…10.0.19041.1466x86ntdsutil.exeWin10 20H2Winbindex
99e5b79e820f…10.0.19041.844x86ntdsutil.exeWin10 2004UnsignedWinbindex
2dbd433abada…10.0.19041.844x64ntdsutil.exeWin10 2004UnsignedWinbindex
ae736bd0fa09…10.0.18362.628x64ntdsutil.exeWin10 1903, Win10 1909UnsignedWinbindex
8ea6a54c186d…10.0.18362.628x86ntdsutil.exeWin10 1903, Win10 1909Winbindex
b9359e3e5c27…10.0.17134.765x86ntdsutil.exeWin10 1803UnsignedWinbindex
5e8a67c2fe06…10.0.17134.765x64ntdsutil.exeWin10 1803UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.