Library / Windows

nvspinfo.exe

"nvspinfo.PROGRAM" · Microsoft Corporation

WindowsParsed

OriginalFilename

  • "nvspinfo.PROGRAM"

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: nvspinfo.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\nvspinfo.exe'
    - OriginalFileName: '"nvspinfo.PROGRAM"'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
"nvspinfo.PROGRAM"1x6410.0.26100.9711Host scan

InternalName: "nvspinfo.PROGRAM" · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
c03d2eaa38f3…10.0.26100.9711x64"nvspinfo.PROGRAM"Host scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.