Library / LOLBin

odbcad32.exe

ODBC Administrator · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBAS

OriginalFilename

  • odbcad32.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\odbcad32.exe'
    - OriginalFileName: 'odbcad32.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
odbcad32.exe12x64, x8610.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: odbcad32.exe · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
147921c5047b…10.0.28000.1896x64odbcad32.exeWin11 26H1Winbindex
af1e91e5be1e…10.0.28000.1251x86odbcad32.exeWin11 26H1UnsignedWinbindex
894b4701462f…10.0.26100.7019x86odbcad32.exeWin11 24H2UnsignedHost scan, Winbindex✓
35a800867169…10.0.26100.7019x64odbcad32.exeWin11 24H2UnsignedHost scan, Winbindex✓
fde6de4356fc…10.0.26100.5074x64odbcad32.exeWin11 24H2, Win11 25H2UnsignedWinbindex
a9bdc19ffc7b…10.0.26100.5074x86odbcad32.exeWin11 24H2, Win11 25H2UnsignedWinbindex
4b03b05fce50…10.0.14393.0x86odbcad32.exeWin10 1607UnsignedWinbindex
04375aba7e27…10.0.14393.0x64odbcad32.exeWin10 1607UnsignedWinbindex
f28ec229c7fa…10.0.10586.0x86odbcad32.exeWin10 1511UnsignedWinbindex
6ca8a9382076…10.0.10586.0x64odbcad32.exeWin10 1511UnsignedWinbindex
b4be4ca9053d…10.0.10240.16384x86odbcad32.exeWin10 1507UnsignedWinbindex
33dd559b3b7e…10.0.10240.16384x64odbcad32.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.